Joomla RuleZ

Installation of JWPlayer Advanced Plugin Failed

  • webdevtim
  • webdevtim's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
2 years 10 months ago #7871 by webdevtim
Replied by webdevtim on topic Installation of JWPlayer Advanced Plugin Failed
I actually added:
$doc->addStyleSheet('templates/'.$this->template.'/css/jwplayer/911to-std.css');

I will go ahead and remove this since the plugin already sets this.

Please Log in or Create an account to join the conversation.

  • webdevtim
  • webdevtim's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
2 years 10 months ago - 2 years 10 months ago #7872 by webdevtim
Replied by webdevtim on topic Installation of JWPlayer Advanced Plugin Failed
This is extremely irritating. I thought I had the JWPlayer styles set and now because JWPlayer makes some changes my styles are no longer being applied. Their documentation is confusing and almost non existent and JoomlaRulez in no better.

I REALLY DON'T HAVE TIME TO DEAL WITH THIS RIGHT NOW but it would seem that I have no choice.

Probably nothing you can do about this, but before the last update everything displayed exactly the way I wanted it to display and now I have a mess and I didn't make any changes on my end.

I changed the JWPlayer Version in Global Parameters from cdn7 to 7 and my styles are working again, but the dimensions of the play button changed so the play triangle is no longer centered.

I will go through each and every style and specifically set each and I will include those styles in my template.css file so that they don't get over-written by some subsequent upgrade.
Last edit: 2 years 10 months ago by webdevtim. Reason: Because I Wanted To

Please Log in or Create an account to join the conversation.

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Administrator
  • Coding is good
More
2 years 10 months ago #7873 by admin
The first issue don't come from jwplayer or Joomlarulez, it comes from Joomla itself and this the last version of 3.6.x, about the skin selection it's the same issue, we haven't change anything on how set a skin, it's a bug from Joomla, as we are using as well the folder parameter list selection of Joomla.

Then building his own skin is difficult and subject to any evolution of the player skin structure, this why if you are not an expert in css it's better to use the premium skin or to not update if you don't need to.

Please Log in or Create an account to join the conversation.

  • webdevtim
  • webdevtim's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
2 years 10 months ago - 2 years 10 months ago #7874 by webdevtim
Replied by webdevtim on topic Installation of JWPlayer Advanced Plugin Failed
I am an expert in CSS.

I changed the JW Player Version to '7' instead of 'cdn7' and that should solve the problem of my classes being ignored. Changes in the JWPlayer skin structure will always affect the styles I set, because margins, paddings, changed will throw off the alignment of elements I have set on the page. But since I am now using the '7' version of the player skin instead of the 'cdn7' version I would think that changes in the cloud version of the skin will not longer affect the styles I set.

The JWPlayer documentation concerning Custom Skins is not very comprehensive or complete complete. JoomlaRulez pdf documentation for the plugin and module by contrast is quite complete.

I am sorry, but I am under a very tight deadline to get a role out of the re-branded website ready and I wasn't expecting to have to deal with the video player at this moment.

I will specifically set every style for the player so that there can be no uncertainty when updates are applied.

This is from JWPlayer and they give no example on what they expect to be entered here.

DNS MASKING

Mask our content server to serve feeds, players, thumbs, and videos under your own domain. You must first set a CNAME record in your domain DNS settings with your hosting provider.


I created a CNAME record on our host's name-server like:

media.911tap.org - 3600 - CNAME - content.jwplatform.com

and on the JWPlayer account

I added the CNAME -> media.911tap.org in the DNS Masking section.

I would expect that after doing this videos would be referenced like:

media.911tap.org/videos/uY05ITYy-c1CZ03OE.m4a instead of

content.jwplatform.com/videos/uY05ITYy-c1CZ03OE.m4a

Is there anything in the JWPlayer plugin and modules that I need to update for this to take effect?

What do I need to do to be able to enable the secure video feature on JWPLayer. We have SSL Certificates installed on our host and our cloud service.
Last edit: 2 years 10 months ago by webdevtim.

Please Log in or Create an account to join the conversation.

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Administrator
  • Coding is good
More
2 years 10 months ago #7875 by admin
Your are opening to many questions at once...

about css skin, as I said if you don't want to re edit your css each time jwplayer.com make an update then use the premium skin.

DNS masking is not support by our extension, if you want it you have to use jwplayer without it, I suggest you to contact jwplayer directly.

what secure video on jwplayer.com are you talking ? sign url ? i

Please Log in or Create an account to join the conversation.

  • webdevtim
  • webdevtim's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
2 years 10 months ago - 2 years 10 months ago #7876 by webdevtim
Replied by webdevtim on topic Installation of JWPlayer Advanced Plugin Failed
Thank you for your patience.

I have the skins working as it was prior to the Joomla Upgrade to 3.6.2 and as long as Joomla applies those patches to the next release, there shouldn't be any further problems.

Sorry I got angry.

As far as DNS Masking, all I think I need to do is modify your plugin to use my alias for content.jwplatorm.com, media.911tap.org and I think it would work. I will just have to remember to keep backups of the files I modify so that when you release an update, I will be able to re-apply those modifications.

As far as secure URLs, I would assume that means using https instead of http when linking to videos on JWPlayer. JWPlayer has a switch for that under player - settings.

Thanks for your help, I will try to deal with pressure more gracefully in the future.

You can see that everything is working OK here:

http://webdev.911truthoutreach.org/tap-media/broadcast-psas/1048-psas/460-public-service-announcements
Last edit: 2 years 10 months ago by webdevtim.

Please Log in or Create an account to join the conversation.

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Administrator
  • Coding is good
More
2 years 10 months ago #7877 by admin
Glad to see it's working now :)

Please Log in or Create an account to join the conversation.

  • webdevtim
  • webdevtim's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
2 years 10 months ago #7878 by webdevtim
Replied by webdevtim on topic Installation of JWPlayer Advanced Plugin Failed
Actually I am having a problem with HLS streaming, but I see that there is another post dealing with that.

I want to load videos by Media ID and it was the suggested by JWPlayer to use:

file=http://content.jwplatform.com/manifests/MQ6z2tHb.m3u8&type=hls

But I just got the message that the media couldn't be found

Would this be the proper way to add this.

Please Log in or Create an account to join the conversation.

  • admin
  • admin's Avatar
  • Offline
  • Administrator
  • Administrator
  • Coding is good
More
2 years 10 months ago #7879 by admin
try :
&file=http://content.jwplatform.com/manifests/MQ6z2tHb.m3u8&type=hls

If it still don't work please provide a test page URL

Please Log in or Create an account to join the conversation.

  • webdevtim
  • webdevtim's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
More
2 years 10 months ago #7880 by webdevtim
Replied by webdevtim on topic Installation of JWPlayer Advanced Plugin Failed
Let me read the documentation again and make sure that I have set everything that needs to be set, make sure that the crossdomain.xml file is correct and then try it again.

What k,ind of a test page to you want, do you need admin access?

Please Log in or Create an account to join the conversation.

Time to create page: 0.294 seconds
You are here: Home Forum Joomla RuleZ Forum Support Plugin Installation of JWPlayer Advanced Plugin Failed